Difference between revisions of "Dependencies"

From LinuxIntro
Jump to: navigation, search
(libQtDBus)
Line 9: Line 9:
  
 
= libQtDBus =
 
= libQtDBus =
;Problem, in this case from [[skype]]:
+
Problem, in this case from [[skype]]:
 
  skype: error while loading shared libraries: libQtDBus.so.4: cannot open shared object file: No such file or directory
 
  skype: error while loading shared libraries: libQtDBus.so.4: cannot open shared object file: No such file or directory
;Reason: You do not have the 32bit libraries for Qt.
+
Reason: You do not have the 32bit libraries for Qt.
 +
 
 
;Solution, in this case for SUSE 11.3:
 
;Solution, in this case for SUSE 11.3:
 
  yast -i libqt4-32bit
 
  yast -i libqt4-32bit
  
 +
= libQtGui =
 +
Problem, in this case from [[skype]]:
 +
skype: error while loading shared libraries: libQtGui.so.4: cannot open shared object file: No such file or directory
 +
Reason: You do not have the 32bit libraries for Qt.
 +
 +
Solution:
 +
yast -i libqt4-x11-32bit
  
 
= libXm =
 
= libXm =

Revision as of 19:40, 31 October 2010

This page lists dependency problems and solutions to them. Note that your individual problem may require a different solution, however, this is a starting point.


Contents

libQt

Problem, in this case by umtsmon:

./umtsmon: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory

Solution, in this case for SUSE 11.3:

yast -i qt3-32bit

libQtDBus

Problem, in this case from skype:

skype: error while loading shared libraries: libQtDBus.so.4: cannot open shared object file: No such file or directory

Reason: You do not have the 32bit libraries for Qt.

Solution, in this case for SUSE 11.3
yast -i libqt4-32bit

libQtGui

Problem, in this case from skype:

skype: error while loading shared libraries: libQtGui.so.4: cannot open shared object file: No such file or directory

Reason: You do not have the 32bit libraries for Qt.

Solution:

yast -i libqt4-x11-32bit

libXm

error: Failed dependencies:
        libXm.so.4 is needed by ICAClient-11.0-1.i386
rpm -qf /usr/lib64/libXm.so.4
openmotif-libs-2.3.1-3.13

libXv

# rpm -ivh Downloads/RealPlayer11GOLD.rpm 
error: Failed dependencies:
        libXv.so.1 is needed by realplay-11.0.2.1744-1.i386
# yast -i xorg-x11-libXv-32bit